summaryrefslogtreecommitdiff
path: root/home/cez/modules/wayland.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/cez/modules/wayland.nix')
-rw-r--r--home/cez/modules/wayland.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/home/cez/modules/wayland.nix b/home/cez/modules/wayland.nix
new file mode 100644
index 0000000..4c9e0ac
--- /dev/null
+++ b/home/cez/modules/wayland.nix
@@ -0,0 +1,8 @@
+{ pkgs, ... }: let
+ wayland-scripts = pkgs.callPackage ../../wayland/pkgs/wayland-scripts {};
+ freezshot = "${wayland-scripts}/bin/freezshot";
+in {
+ # vendor hardcoded screenshot key
+ wayland.windowManager.sway.settings.bindsym."mod4+shift+s" =
+ "exec ${freezshot}";
+}