summaryrefslogtreecommitdiff
path: root/home/common/home.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/common/home.nix')
-rw-r--r--home/common/home.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/home/common/home.nix b/home/common/home.nix
new file mode 100644
index 0000000..8ec0757
--- /dev/null
+++ b/home/common/home.nix
@@ -0,0 +1,13 @@
+{ config, ... }: let
+ username = config.userdata.name;
+in {
+ imports = [ ./modules/git.nix ];
+
+ programs.home-manager.enable = true;
+
+ home = {
+ inherit username;
+ stateVersion = "23.11";
+ homeDirectory = "/home/${config.home.username}";
+ };
+}