summaryrefslogtreecommitdiff
path: root/home/common/home.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/common/home.nix')
-rw-r--r--home/common/home.nix16
1 files changed, 14 insertions, 2 deletions
diff --git a/home/common/home.nix b/home/common/home.nix
index b2ca191..c103a3f 100644
--- a/home/common/home.nix
+++ b/home/common/home.nix
@@ -1,4 +1,4 @@
-{ config, ... }: let
+{ config, pkgs, ... }: let
username = config.global.userdata.name;
in {
imports = [
@@ -7,10 +7,22 @@ in {
];
programs.home-manager.enable = true;
-
home = {
inherit username;
stateVersion = "24.11";
homeDirectory = "/home/${config.home.username}";
+
+ packages = with pkgs; [
+ unzip
+ htop
+ curl
+ file
+ dig
+ tcpdump
+ mtr
+ nnn
+ ps_mem
+ geoipWithDatabase
+ ];
};
}