summaryrefslogtreecommitdiff
path: root/home/common/modules/git.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/common/modules/git.nix')
-rw-r--r--home/common/modules/git.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/home/common/modules/git.nix b/home/common/modules/git.nix
new file mode 100644
index 0000000..7337f7b
--- /dev/null
+++ b/home/common/modules/git.nix
@@ -0,0 +1,15 @@
+{ config, ... }: let
+ userName = config.userdata.nameFq;
+ userEmail = config.userdata.email;
+in {
+ programs.git = {
+ enable = true;
+ inherit userName;
+ inherit userEmail;
+
+ extraConfig = {
+ color.ui = "auto";
+ init.defaultBranch = "master";
+ };
+ };
+}