summaryrefslogtreecommitdiff
path: root/home/wayland/modules/foot.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/wayland/modules/foot.nix')
-rw-r--r--home/wayland/modules/foot.nix3
1 files changed, 1 insertions, 2 deletions
diff --git a/home/wayland/modules/foot.nix b/home/wayland/modules/foot.nix
index 77299aa..5f6c898 100644
--- a/home/wayland/modules/foot.nix
+++ b/home/wayland/modules/foot.nix
@@ -1,8 +1,7 @@
{ config, lib, ... }: let
font = config.global.font.monospace.name
- + ":size="
+ lib.optionalString (config.global.font.monospace.size != null)
- (builtins.toString config.global.font.monospace.size);
+ ":size=" + builtins.toString config.global.font.monospace.size;
in {
programs.foot = {
enable = true;