summaryrefslogtreecommitdiff
path: root/home/wayland/modules/mango.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/wayland/modules/mango.nix')
-rw-r--r--home/wayland/modules/mango.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/home/wayland/modules/mango.nix b/home/wayland/modules/mango.nix
new file mode 100644
index 0000000..31cd7d6
--- /dev/null
+++ b/home/wayland/modules/mango.nix
@@ -0,0 +1,29 @@
+{ ... }: {
+ programs.mangohud = {
+ enable = true;
+
+ settings = {
+ horizontal = true;
+ legacy_layout = 0;
+ hud_no_margin = true;
+ gpu_stats = true;
+ gpu_temp = true;
+ gpu_core_clock = true;
+ gpu_mem_clock = true;
+ gpu_power = true;
+ gpu_name = true;
+ cpu_stats = true;
+ cpu_temp = true;
+ cpu_power = true;
+ cpu_mhz = true;
+ vram = true;
+ vram_color = "ad64c1";
+ ram = true;
+ ram_color = "c26693";
+ fps = true;
+ frame_timing = 1;
+ frametime_color = "00ff00";
+ text_color = "ffffff";
+ };
+ };
+}