summaryrefslogtreecommitdiff
path: root/home/wayland/modules/zathura.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home/wayland/modules/zathura.nix')
-rw-r--r--home/wayland/modules/zathura.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/home/wayland/modules/zathura.nix b/home/wayland/modules/zathura.nix
index 8437e80..9a013da 100644
--- a/home/wayland/modules/zathura.nix
+++ b/home/wayland/modules/zathura.nix
@@ -1,4 +1,9 @@
-{ lib, ... }: {
+{ config, lib, ... }: let
+ font = config.global.font.sans.name
+ + " "
+ + lib.optionalString (config.global.font.sans.size != null)
+ (builtins.toString config.global.font.sans.size);
+in {
programs.zathura = {
enable = true;
@@ -7,7 +12,7 @@
"[fullscreen] f" = "toggle_fullscreen";
};
options = {
- font = lib.mkDefault "Sans";
+ inherit font;
statusbar-basename = true;
selection-clipboard = "clipboard";
database = "sqlite";