summaryrefslogtreecommitdiff
path: root/hosts/cez.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/cez.nix')
-rw-r--r--hosts/cez.nix28
1 files changed, 17 insertions, 11 deletions
diff --git a/hosts/cez.nix b/hosts/cez.nix
index 2b6ebb4..bf9ffde 100644
--- a/hosts/cez.nix
+++ b/hosts/cez.nix
@@ -1,5 +1,8 @@
-{ pkgs, ... }:
+{ config, pkgs, ... }:
+let
+ user = config.userdata.user;
+in
{
imports = [
../modules/wayland.nix
@@ -12,13 +15,6 @@
consoleLogLevel = 3;
kernelPackages = pkgs.linuxPackages_latest;
};
-
- networking = {
- hostName = "cez";
- dhcpcd.wait = "background";
- wireless.iwd.enable = true;
- };
-
sound = {
enable = true;
extraConfig = ''
@@ -26,8 +22,18 @@
defaults.ctl.card 1
'';
};
- services.pipewire = {
- enable = true;
- pulse.enable = true;
+
+ networking = {
+ hostName = "cez";
+ dhcpcd.wait = "background";
+ wireless.iwd.enable = true;
+ };
+
+ services = {
+ getty.autologinUser = user;
+ pipewire = {
+ enable = true;
+ pulse.enable = true;
+ };
};
}