summaryrefslogtreecommitdiff
path: root/hosts/cez/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/cez/configuration.nix')
-rw-r--r--hosts/cez/configuration.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/hosts/cez/configuration.nix b/hosts/cez/configuration.nix
new file mode 100644
index 0000000..ac2d2ea
--- /dev/null
+++ b/hosts/cez/configuration.nix
@@ -0,0 +1,40 @@
+{ config, pkgs, ... }:
+
+let
+ user = config.userdata.user;
+in
+{
+ imports = [
+ ./hardware-configuration.nix
+ ../../modules/wayland.nix
+ ../../modules/sshfs.nix
+ ../common.nix
+ ];
+
+ boot = {
+ initrd.luks.reusePassphrases = true;
+ consoleLogLevel = 3;
+ kernelPackages = pkgs.linuxPackages_latest;
+ };
+ sound = {
+ enable = true;
+ extraConfig = ''
+ defaults.pcm.card 1
+ defaults.ctl.card 1
+ '';
+ };
+
+ networking = {
+ hostName = "cez";
+ dhcpcd.wait = "background";
+ wireless.iwd.enable = true;
+ };
+
+ services = {
+ getty.autologinUser = user;
+ pipewire = {
+ enable = true;
+ pulse.enable = true;
+ };
+ };
+}