summaryrefslogtreecommitdiff
path: root/hosts/cez/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/cez/configuration.nix')
-rw-r--r--hosts/cez/configuration.nix47
1 files changed, 0 insertions, 47 deletions
diff --git a/hosts/cez/configuration.nix b/hosts/cez/configuration.nix
deleted file mode 100644
index 6a801b0..0000000
--- a/hosts/cez/configuration.nix
+++ /dev/null
@@ -1,47 +0,0 @@
-{ config, pkgs, ... }:
-
-let
- user = config.userdata.user;
-in
-{
- imports = [
- ./hardware-configuration.nix
- ./modules/wayland.nix
- ./modules/sshfs.nix
- ./modules/wireguard.nix
- ./modules/network.nix
- ../../common.nix
- ];
-
- boot = {
- initrd.luks.reusePassphrases = true;
- consoleLogLevel = 3;
- kernelPackages = pkgs.linuxPackages_latest;
- };
-
- sound = {
- enable = true;
- extraConfig = ''
- defaults.pcm.card 1
- defaults.ctl.card 1
- '';
- };
-
- services = {
- pipewire = {
- enable = true;
- pulse.enable = true;
- };
- getty.autologinUser = user;
- };
-
- programs.adb.enable = true;
- users.users.${user} = {
- extraGroups = [ "adbusers" ];
- packages = with pkgs; [
- geoipWithDatabase
- ffmpeg
- (pass.withExtensions (exts: [ exts.pass-otp ]))
- ];
- };
-}