summaryrefslogtreecommitdiff
path: root/hosts/cez/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/cez/hardware-configuration.nix')
-rw-r--r--hosts/cez/hardware-configuration.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/hosts/cez/hardware-configuration.nix b/hosts/cez/hardware-configuration.nix
index a1107c1..19313e5 100644
--- a/hosts/cez/hardware-configuration.nix
+++ b/hosts/cez/hardware-configuration.nix
@@ -4,6 +4,11 @@
imports = [ (modulesPath + "/installer/scan/not-detected.nix") ];
boot = {
+ loader = {
+ systemd-boot.enable = true;
+ efi.canTouchEfiVariables = true;
+ };
+
kernelModules = [ "kvm-amd" ];
initrd = {
availableKernelModules = [
@@ -15,7 +20,8 @@
"sdhci_pci"
];
- luks.devices."crypt".device = "/dev/disk/by-uuid/84acd784-caad-41a1-a2e4-39468d01fefd";
+ luks.devices."crypt".device =
+ "/dev/disk/by-uuid/84acd784-caad-41a1-a2e4-39468d01fefd";
};
};