summaryrefslogtreecommitdiff
path: root/hosts/cez/modules/sshfs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/cez/modules/sshfs.nix')
-rw-r--r--hosts/cez/modules/sshfs.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/hosts/cez/modules/sshfs.nix b/hosts/cez/modules/sshfs.nix
new file mode 100644
index 0000000..a1f1904
--- /dev/null
+++ b/hosts/cez/modules/sshfs.nix
@@ -0,0 +1,22 @@
+{ config, pkgs, ... }:
+
+let
+ user = config.userdata.user;
+ domain = config.userdata.domain;
+in
+{
+ system.fsPackages = with pkgs; [ sshfs ];
+
+ fileSystems."/kay" = {
+ device = "${user}@${domain}:";
+ fsType = "sshfs";
+ options = [
+ "allow_other" # for non-root access
+ "_netdev" # this is a network fs
+ "x-systemd.automount" # mount on demand
+ "reconnect" # handle connection drops
+ "ServerAliveInterval=15" # keep connections alive
+ "IdentityFile=/var/secrets/ssh/${user}.key"
+ ];
+ };
+}