summaryrefslogtreecommitdiff
path: root/hosts/cez/modules/sshfs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/cez/modules/sshfs.nix')
-rw-r--r--hosts/cez/modules/sshfs.nix27
1 files changed, 0 insertions, 27 deletions
diff --git a/hosts/cez/modules/sshfs.nix b/hosts/cez/modules/sshfs.nix
deleted file mode 100644
index a9ff183..0000000
--- a/hosts/cez/modules/sshfs.nix
+++ /dev/null
@@ -1,27 +0,0 @@
-{ config, pkgs, ... }:
-
-let
- domain = config.userdata.domain;
- user = config.userdata.user;
- uid = config.users.users.${user}.uid;
- gid = config.users.groups.users.gid;
-in
-{
- sops.secrets."misc/sftp" = {};
- system.fsPackages = with pkgs; [ sshfs ];
-
- fileSystems."/kay" = {
- device = "sftp@${domain}:";
- fsType = "sshfs";
- options = [
- "allow_other" # for non-root access
- "uid=${toString uid}"
- "gid=${toString gid}"
- "_netdev" # this is a network fs
- "x-systemd.automount" # mount on demand
- "reconnect" # handle connection drops
- "ServerAliveInterval=15" # keep connections alive
- "IdentityFile=${config.sops.secrets."misc/sftp".path}"
- ];
- };
-}