summaryrefslogtreecommitdiff
path: root/hosts/cez/modules/wireguard.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/cez/modules/wireguard.nix')
-rw-r--r--hosts/cez/modules/wireguard.nix27
1 files changed, 0 insertions, 27 deletions
diff --git a/hosts/cez/modules/wireguard.nix b/hosts/cez/modules/wireguard.nix
deleted file mode 100644
index d8e8dd0..0000000
--- a/hosts/cez/modules/wireguard.nix
+++ /dev/null
@@ -1,27 +0,0 @@
-{ config, ... }:
-
-let
- domain = config.userdata.domain;
-in
-{
- sops.secrets."misc/wireguard" = {};
-
- networking.wg-quick.interfaces."kay" = {
- autostart = false;
- address = [ "10.0.1.2/24" ];
- dns = [ "10.0.1.1" ];
- mtu = 1380;
- privateKeyFile = config.sops.secrets."misc/wireguard".path;
-
- peers = [{
- publicKey = "wJMyQDXmZO4MjYRk6NK4+J6ZKWLTTZygAH+OwbPjOiw=";
- allowedIPs = [
- "10.0.1.0/24"
- "104.16.0.0/12"
- "172.64.0.0/13"
- ];
- endpoint = "${domain}:51820";
- persistentKeepalive = 25;
- }];
- };
-}