summaryrefslogtreecommitdiff
path: root/hosts/dspace/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/dspace/hardware-configuration.nix')
-rw-r--r--hosts/dspace/hardware-configuration.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/hosts/dspace/hardware-configuration.nix b/hosts/dspace/hardware-configuration.nix
new file mode 100644
index 0000000..c355e8b
--- /dev/null
+++ b/hosts/dspace/hardware-configuration.nix
@@ -0,0 +1,27 @@
+{ lib, modulesPath, ... }:
+
+{
+ imports = [ (modulesPath + "/profiles/qemu-guest.nix") ];
+
+ boot.initrd.availableKernelModules = [
+ "ata_piix"
+ "uhci_hcd"
+ "virtio_pci"
+ "virtio_scsi"
+ "sd_mod"
+ "sr_mod"
+ ];
+
+ fileSystems = {
+ "/" = {
+ device = "/dev/disk/by-uuid/c5b1077e-52e8-4249-8bd7-d53eafa41f5a";
+ fsType = "ext4";
+ };
+ "/boot" = {
+ device = "/dev/disk/by-uuid/9787-FFFE";
+ fsType = "vfat";
+ };
+ };
+
+ nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+}