summaryrefslogtreecommitdiff
path: root/hosts/dspace/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/dspace/hardware-configuration.nix')
-rw-r--r--hosts/dspace/hardware-configuration.nix23
1 files changed, 15 insertions, 8 deletions
diff --git a/hosts/dspace/hardware-configuration.nix b/hosts/dspace/hardware-configuration.nix
index c355e8b..aaad3b7 100644
--- a/hosts/dspace/hardware-configuration.nix
+++ b/hosts/dspace/hardware-configuration.nix
@@ -3,14 +3,21 @@
{
imports = [ (modulesPath + "/profiles/qemu-guest.nix") ];
- boot.initrd.availableKernelModules = [
- "ata_piix"
- "uhci_hcd"
- "virtio_pci"
- "virtio_scsi"
- "sd_mod"
- "sr_mod"
- ];
+ boot = {
+ loader = {
+ systemd-boot.enable = true;
+ efi.canTouchEfiVariables = true;
+ };
+
+ initrd.availableKernelModules = [
+ "ata_piix"
+ "uhci_hcd"
+ "virtio_pci"
+ "virtio_scsi"
+ "sd_mod"
+ "sr_mod"
+ ];
+ };
fileSystems = {
"/" = {