summaryrefslogtreecommitdiff
path: root/hosts/dspace/modules/network.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/dspace/modules/network.nix')
-rw-r--r--hosts/dspace/modules/network.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/hosts/dspace/modules/network.nix b/hosts/dspace/modules/network.nix
new file mode 100644
index 0000000..007cfba
--- /dev/null
+++ b/hosts/dspace/modules/network.nix
@@ -0,0 +1,18 @@
+{ ... }:
+
+let
+ wan = "ens18";
+in
+{
+ networking = {
+ interfaces.${wan}.ipv4.addresses = [{
+ address = "10.0.8.107";
+ prefixLength = 16;
+ }];
+ defaultGateway = {
+ address = "10.0.0.1";
+ interface = wan;
+ };
+ nameservers = [ "10.0.0.2" "10.0.0.3" ];
+ };
+}