summaryrefslogtreecommitdiff
path: root/hosts/kay/modules/acme.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/kay/modules/acme.nix')
-rw-r--r--hosts/kay/modules/acme.nix23
1 files changed, 0 insertions, 23 deletions
diff --git a/hosts/kay/modules/acme.nix b/hosts/kay/modules/acme.nix
deleted file mode 100644
index f4ded0a..0000000
--- a/hosts/kay/modules/acme.nix
+++ /dev/null
@@ -1,23 +0,0 @@
-{ config, pkgs, ... }: let
- email = config.userdata.email;
- domain = config.userdata.domain;
-
- environmentFile =
- pkgs.writeText "acme-dns" "RFC2136_NAMESERVER='[2001:470:ee65::1]:53'";
-in {
- security.acme = {
- acceptTerms = true;
- defaults.email = email;
-
- certs.${domain} = {
- inherit domain;
- extraDomainNames = [ "*.${domain}" ];
-
- dnsProvider = "rfc2136";
- dnsPropagationCheck = false; # local DNS server
-
- inherit environmentFile;
- group = config.services.nginx.group;
- };
- };
-}