summaryrefslogtreecommitdiff
path: root/hosts/kay/modules/mail.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/kay/modules/mail.nix')
-rw-r--r--hosts/kay/modules/mail.nix20
1 files changed, 14 insertions, 6 deletions
diff --git a/hosts/kay/modules/mail.nix b/hosts/kay/modules/mail.nix
index cd47d39..63959b8 100644
--- a/hosts/kay/modules/mail.nix
+++ b/hosts/kay/modules/mail.nix
@@ -92,12 +92,20 @@ in {
type = "memory";
options.subaddressing = true;
- principals = [{
- inherit email;
- inherit secret;
- name = username;
- type = "admin";
- }];
+ principals = [
+ {
+ inherit email;
+ inherit secret;
+ name = username;
+ type = "admin";
+ }
+ { # for mta-sts & dmarc reports
+ email = "reports${domain}";
+ inherit secret;
+ name = "reports";
+ type = "individual";
+ }
+ ];
};
};
};