summaryrefslogtreecommitdiff
path: root/hosts/kay/modules/network.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/kay/modules/network.nix')
-rw-r--r--hosts/kay/modules/network.nix20
1 files changed, 5 insertions, 15 deletions
diff --git a/hosts/kay/modules/network.nix b/hosts/kay/modules/network.nix
index 5e1b2ee..929fb1b 100644
--- a/hosts/kay/modules/network.nix
+++ b/hosts/kay/modules/network.nix
@@ -1,11 +1,10 @@
-{ config, pkgs, ... }:
+{ config, ... }:
let
inetVlan = 722;
voipVlan = 1849;
wanInterface = "enp4s0";
nameServer = "1.0.0.1";
- domain = config.userdata.domain;
in
{
imports = [
@@ -17,7 +16,6 @@ in
"ppp/chap-secrets" = {};
"ppp/pap-secrets" = {};
"ppp/username" = {};
- "misc/namecheap.com" = {};
};
networking = let
@@ -50,8 +48,10 @@ in
bind-interfaces = true;
};
};
+
pppd = {
enable = true;
+
config = ''
plugin pppoe.so
debug
@@ -66,27 +66,17 @@ in
lcp-echo-interval 1
lcp-echo-failure 5
'';
+
peers.bsnl = {
enable = true;
autostart = true;
configFile = config.sops.secrets."ppp/username".path;
};
+
secret = {
chap = config.sops.secrets."ppp/chap-secrets".path;
pap = config.sops.secrets."ppp/pap-secrets".path;
};
- script."01-ddns" = {
- runtimeInputs = with pkgs; [ curl coreutils ];
- text = ''
- wan_ip="$4"
- api_key="$(cat ${config.sops.secrets."misc/namecheap.com".path})"
- auth_url="https://dynamicdns.park-your-domain.com/update?host=@&domain=${domain}&password=''${api_key}&ip="
-
- until curl --silent "$auth_url$wan_ip"; do
- sleep 1
- done
- '';
- };
};
};
}