summaryrefslogtreecommitdiff
path: root/hosts/kay/modules/network.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/kay/modules/network.nix')
-rw-r--r--hosts/kay/modules/network.nix13
1 files changed, 10 insertions, 3 deletions
diff --git a/hosts/kay/modules/network.nix b/hosts/kay/modules/network.nix
index f5e5d5b..b14cb9a 100644
--- a/hosts/kay/modules/network.nix
+++ b/hosts/kay/modules/network.nix
@@ -20,19 +20,26 @@ in
"misc/namecheap.com" = {};
};
- networking = {
+ networking = let
+ voipVlanIface = "voip";
+ in {
vlans = {
wan = {
id = inetVlan;
interface = wanInterface;
};
- voip = {
+ ${voipVlanIface} = {
id = voipVlan;
interface = wanInterface;
};
};
- interfaces."voip".useDHCP = true;
+ interfaces.${voipVlanIface}.useDHCP = true;
+ dhcpcd.extraConfig = ''
+ interface ${voipVlanIface}
+ ipv4only
+ nogateway
+ '';
};
services = {