summaryrefslogtreecommitdiff
path: root/hosts/kay/modules/router.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/kay/modules/router.nix')
-rw-r--r--hosts/kay/modules/router.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/hosts/kay/modules/router.nix b/hosts/kay/modules/router.nix
index cf748ce..cc9aaae 100644
--- a/hosts/kay/modules/router.nix
+++ b/hosts/kay/modules/router.nix
@@ -1,15 +1,17 @@
{ ... }:
let
- lanInterface = "enp4s0";
+ lanInterface = "enp0s20u1";
wanInterface = "ppp0";
subnet = "10.0.0.0";
prefix = 24;
host = "10.0.0.1";
leaseRangeStart = "10.0.0.100";
- leaseRangeEnd = "10.0.0.240";
+ leaseRangeEnd = "10.0.0.254";
in
{
+ imports = [ ./wireguard.nix ];
+
networking = {
nat = {
enable = true;