summaryrefslogtreecommitdiff
path: root/hosts/kay/modules/router.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/kay/modules/router.nix')
-rw-r--r--hosts/kay/modules/router.nix8
1 files changed, 1 insertions, 7 deletions
diff --git a/hosts/kay/modules/router.nix b/hosts/kay/modules/router.nix
index c621620..cc9aaae 100644
--- a/hosts/kay/modules/router.nix
+++ b/hosts/kay/modules/router.nix
@@ -1,7 +1,7 @@
{ ... }:
let
- lanInterface = "enp4s0";
+ lanInterface = "enp0s20u1";
wanInterface = "ppp0";
subnet = "10.0.0.0";
prefix = 24;
@@ -24,12 +24,6 @@ in
address = host;
prefixLength = prefix;
}];
- # the mac id of the built-in nic is required for
- # ppp authentication with isp, this is here to avoid
- # mac address collision since it's original mac id is used
- # by the new wan interface for ppp authentication
- # see ./network.nix
- macAddress = "40:ed:00:08:ba:be";
};
firewall = {
allowedUDPPorts = [ 53 67 ];