summaryrefslogtreecommitdiff
path: root/hosts/kay/modules/www.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/kay/modules/www.nix')
-rw-r--r--hosts/kay/modules/www.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/hosts/kay/modules/www.nix b/hosts/kay/modules/www.nix
index 2b0c7fb..a81adc2 100644
--- a/hosts/kay/modules/www.nix
+++ b/hosts/kay/modules/www.nix
@@ -4,6 +4,7 @@ let
domain = config.userdata.domain;
email = config.userdata.email;
fscusat = "fscusat.org";
+ mark = "themark.ing";
in
{
imports = [
@@ -62,6 +63,20 @@ in
extraConfig = "add_header Content-Type text/html;";
};
};
+ "${mark}" = {
+ forceSSL = true;
+ enableACME = true;
+ globalRedirect = "www.${mark}";
+ };
+ "www.${mark}" = {
+ forceSSL = true;
+ enableACME = true;
+
+ locations."/" = {
+ return = "200 '<h1>under construction, see you soon</h1>'";
+ extraConfig = "add_header Content-Type text/html;";
+ };
+ };
};
};
}