summaryrefslogtreecommitdiff
path: root/hosts/lia/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/lia/hardware-configuration.nix')
-rw-r--r--hosts/lia/hardware-configuration.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/hosts/lia/hardware-configuration.nix b/hosts/lia/hardware-configuration.nix
new file mode 100644
index 0000000..6f4c6a4
--- /dev/null
+++ b/hosts/lia/hardware-configuration.nix
@@ -0,0 +1,29 @@
+{ modulesPath, ... }:
+
+{
+ imports = [ (modulesPath + "/installer/scan/not-detected.nix") ];
+
+ boot = {
+ loader.grub = {
+ enable = true;
+ device = "/dev/sda";
+ };
+
+ kernelModules = [ "kvm-intel" ];
+ initrd.availableKernelModules = [
+ "uhci_hcd"
+ "ehci_pci"
+ "ata_piix"
+ "hpsa"
+ "usb_storage"
+ "usbhid"
+ "sd_mod"
+ "sr_mod"
+ ];
+ };
+
+ fileSystems."/" = {
+ device = "/dev/disk/by-uuid/99fc38a8-9003-4ae2-98f4-e08afd9b4114";
+ fsType = "ext4";
+ };
+}