summaryrefslogtreecommitdiff
path: root/modules/iwd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/iwd.nix')
-rw-r--r--modules/iwd.nix27
1 files changed, 15 insertions, 12 deletions
diff --git a/modules/iwd.nix b/modules/iwd.nix
index 0c1c94a..23b740a 100644
--- a/modules/iwd.nix
+++ b/modules/iwd.nix
@@ -74,19 +74,22 @@ in
restartTriggers = [ configFile ];
};
})
- (let
- needResolv = cfg.enable
- && lib.hasAttrByPath [ "Network" "NameResolvingService" ] cfg.settings
- && cfg.settings.Network.NameResolvingService == "resolvconf";
- in
- mkIf needResolv {
- environment.systemPackages = [ pkgs.openresolv ];
- systemd.services.iwd = {
- path = [ pkgs.openresolv ];
- serviceConfig.ReadWritePaths = "/etc/resolv.conf";
- };
- })
+ (
+ let
+ needResolv = cfg.enable
+ && lib.hasAttrByPath [ "Network" "NameResolvingService" ] cfg.settings
+ && cfg.settings.Network.NameResolvingService == "resolvconf";
+ in
+ mkIf needResolv {
+ environment.systemPackages = [ pkgs.openresolv ];
+
+ systemd.services.iwd = {
+ path = [ pkgs.openresolv ];
+ serviceConfig.ReadWritePaths = "/etc/resolv.conf";
+ };
+ }
+ )
];
meta.maintainers = with lib.maintainers; [ dtzWill ];