summaryrefslogtreecommitdiff
path: root/modules/sshfs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/sshfs.nix')
-rw-r--r--modules/sshfs.nix22
1 files changed, 0 insertions, 22 deletions
diff --git a/modules/sshfs.nix b/modules/sshfs.nix
deleted file mode 100644
index a1f1904..0000000
--- a/modules/sshfs.nix
+++ /dev/null
@@ -1,22 +0,0 @@
-{ config, pkgs, ... }:
-
-let
- user = config.userdata.user;
- domain = config.userdata.domain;
-in
-{
- system.fsPackages = with pkgs; [ sshfs ];
-
- fileSystems."/kay" = {
- device = "${user}@${domain}:";
- fsType = "sshfs";
- options = [
- "allow_other" # for non-root access
- "_netdev" # this is a network fs
- "x-systemd.automount" # mount on demand
- "reconnect" # handle connection drops
- "ServerAliveInterval=15" # keep connections alive
- "IdentityFile=/var/secrets/ssh/${user}.key"
- ];
- };
-}