summaryrefslogtreecommitdiff
path: root/modules/userdata.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/userdata.nix')
-rw-r--r--modules/userdata.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/modules/userdata.nix b/modules/userdata.nix
index 84a8ca1..ffb5847 100644
--- a/modules/userdata.nix
+++ b/modules/userdata.nix
@@ -19,5 +19,13 @@ in
default = "sinanmohd.com";
description = mdDoc "Owner's domain";
};
+ pubKeys = mkOption {
+ type = types.listOf types.str;
+ description = mdDoc "Owner's public ssh keys";
+ default = [
+ "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIDCeMXhkjm9CabbA/1xdtP9bvFEm8pVXPk66NmI9/VvQ sinan@veu"
+ "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIL8LnyOuPmtKRqAZeHueNN4kfYvpRQVwCivSTq+SZvDU sinan@cez"
+ ];
+ };
};
}