summaryrefslogtreecommitdiff
path: root/modules/userdata.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/userdata.nix')
-rw-r--r--modules/userdata.nix31
1 files changed, 0 insertions, 31 deletions
diff --git a/modules/userdata.nix b/modules/userdata.nix
deleted file mode 100644
index 00f0e13..0000000
--- a/modules/userdata.nix
+++ /dev/null
@@ -1,31 +0,0 @@
-{ config, lib, ... }:
-
-let
- inherit (lib) mkOption types mdDoc;
- cfg = config.userdata;
-in
-{
- options.userdata = {
- user = mkOption {
- type = types.str;
- default = "sinan";
- description = mdDoc "Owner's username";
- };
- domain = mkOption {
- type = types.str;
- default = "sinanmohd.com";
- description = mdDoc "Owner's domain";
- };
- email = mkOption {
- type = types.str;
- default = "sinan@${cfg.domain}";
- description = mdDoc "Owner's email";
- };
- };
-
- config.users.users.${cfg.user} = {
- uid = 1000;
- isNormalUser = true;
- description = cfg.email;
- };
-}