summaryrefslogtreecommitdiff
path: root/modules/userdata.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/userdata.nix')
-rw-r--r--modules/userdata.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/modules/userdata.nix b/modules/userdata.nix
new file mode 100644
index 0000000..71a5a96
--- /dev/null
+++ b/modules/userdata.nix
@@ -0,0 +1,18 @@
+{ lib, ... }:
+
+let
+ inherit (lib) mkOption types mdDoc;
+in
+{
+ options.userdata = {
+ user = mkOption {
+ type = types.str;
+ default = "sinan";
+ description = mdDoc "owner's username";
+ };
+ groups = mkOption {
+ type = types.listOf types.str;
+ description = mdDoc "Groups the owner should be in";
+ };
+ };
+}