summaryrefslogtreecommitdiff
path: root/os/cez/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'os/cez/configuration.nix')
-rw-r--r--os/cez/configuration.nix46
1 files changed, 46 insertions, 0 deletions
diff --git a/os/cez/configuration.nix b/os/cez/configuration.nix
new file mode 100644
index 0000000..00e755a
--- /dev/null
+++ b/os/cez/configuration.nix
@@ -0,0 +1,46 @@
+{ config, pkgs, ... }:
+
+let
+ user = config.userdata.name;
+in
+{
+ imports = [
+ ../common/configuration.nix
+ ./hardware-configuration.nix
+
+ ./modules/wayland.nix
+ ./modules/sshfs.nix
+ ./modules/wireguard.nix
+ ./modules/network.nix
+ ./modules/tlp.nix
+ ./modules/getty.nix
+ ];
+
+ boot = {
+ consoleLogLevel = 3;
+ kernelPackages = pkgs.linuxPackages_latest;
+ };
+
+ sound = {
+ enable = true;
+ extraConfig = ''
+ defaults.pcm.card 1
+ defaults.ctl.card 1
+ '';
+ };
+
+ services.pipewire = {
+ enable = true;
+ pulse.enable = true;
+ };
+
+ programs.adb.enable = true;
+ users.users.${user} = {
+ extraGroups = [ "adbusers" ];
+ packages = with pkgs; [
+ geoipWithDatabase
+ ffmpeg
+ (pass.withExtensions (exts: [ exts.pass-otp ]))
+ ];
+ };
+}