summaryrefslogtreecommitdiff
path: root/os/cez/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'os/cez/hardware-configuration.nix')
-rw-r--r--os/cez/hardware-configuration.nix30
1 files changed, 1 insertions, 29 deletions
diff --git a/os/cez/hardware-configuration.nix b/os/cez/hardware-configuration.nix
index 5d1a24c..056f65a 100644
--- a/os/cez/hardware-configuration.nix
+++ b/os/cez/hardware-configuration.nix
@@ -1,4 +1,4 @@
-{ modulesPath, nixos-hardware, config, lib, ... }:
+{ modulesPath, nixos-hardware, config, ... }:
{
imports = [
@@ -11,39 +11,11 @@
hardware.amdgpu.initrd.enable = false;
services.xserver.videoDrivers = [ "modesetting" ];
- specialisation.nvidia.configuration = {
- boot = {
- kernelParams = [ "transparent_hugepage=always" ];
- kernel.sysctl."vm.max_map_count" = 2147483642;
- };
-
- environment.variables = {
- DRI_PRIME = 1;
- __NV_PRIME_RENDER_OFFLOAD = 1;
- __VK_LAYER_NV_optimus = "NVIDIA_only";
- __GLX_VENDOR_LIBRARY_NAME = "nvidia";
- };
-
- hardware.nvidia = {
- open = true;
- nvidiaSettings = false;
- prime.sync.enable = true;
- };
-
- services = {
- xserver.videoDrivers = [ "nvidia" ];
- tlp.settings.PLATFORM_PROFILE_ON_AC = lib.mkForce "performance";
- };
- nixpkgs.config.allowUnfreePredicate =
- pkg: builtins.elem (lib.getName pkg) [ "nvidia-x11" ];
- };
-
boot = {
loader.systemd-boot.enable = true;
blacklistedKernelModules = [ "k10temp" ];
extraModulePackages = with config.boot.kernelPackages; [ zenpower ];
-
initrd = {
systemd.enable = true;
luks.devices."crypt".device =