summaryrefslogtreecommitdiff
path: root/os/cez/modules/wayland.nix
diff options
context:
space:
mode:
Diffstat (limited to 'os/cez/modules/wayland.nix')
-rw-r--r--os/cez/modules/wayland.nix41
1 files changed, 0 insertions, 41 deletions
diff --git a/os/cez/modules/wayland.nix b/os/cez/modules/wayland.nix
deleted file mode 100644
index 872c7fb..0000000
--- a/os/cez/modules/wayland.nix
+++ /dev/null
@@ -1,41 +0,0 @@
-{ config, pkgs, ... }: let
- user = config.global.userdata.name;
-
- fontSans = config.global.font.sans.name;
- fontMonospace = config.global.font.monospace.name;
- fontPackages = config.global.font.monospace.packages
- ++ config.global.font.sans.packages;
-in {
- fonts = {
- packages = fontPackages;
- enableDefaultPackages = true;
- fontconfig = {
- hinting.style = "full";
- subpixel.rgba = "rgb";
- defaultFonts = {
- monospace = [ fontMonospace ];
- serif = [ fontSans ];
- sansSerif = [ fontSans ];
- };
- };
- };
-
- users.users.${user}.extraGroups = [ "seat" ];
- services = {
- seatd.enable = true;
- dbus = {
- enable = true;
- implementation = "broker";
- };
- };
-
- programs = {
- gnupg.agent = {
- enable = true;
- pinentryPackage = pkgs.pinentry-bemenu;
- };
- };
-
- security.pam.services.swaylock = {};
- hardware.opengl.enable = true;
-}