summaryrefslogtreecommitdiff
path: root/os/dspace/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'os/dspace/hardware-configuration.nix')
-rw-r--r--os/dspace/hardware-configuration.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/os/dspace/hardware-configuration.nix b/os/dspace/hardware-configuration.nix
new file mode 100644
index 0000000..7a8d7b2
--- /dev/null
+++ b/os/dspace/hardware-configuration.nix
@@ -0,0 +1,32 @@
+{ lib, modulesPath, ... }:
+
+{
+ imports = [ (modulesPath + "/profiles/qemu-guest.nix") ];
+
+ boot = {
+ loader = {
+ systemd-boot.enable = true;
+ efi.canTouchEfiVariables = true;
+ };
+
+ initrd.availableKernelModules = [
+ "ata_piix"
+ "uhci_hcd"
+ "virtio_pci"
+ "virtio_scsi"
+ "sd_mod"
+ "sr_mod"
+ ];
+ };
+
+ fileSystems = {
+ "/" = {
+ device = "/dev/disk/by-uuid/c5b1077e-52e8-4249-8bd7-d53eafa41f5a";
+ fsType = "ext4";
+ };
+ "/boot" = {
+ device = "/dev/disk/by-uuid/9787-FFFE";
+ fsType = "vfat";
+ };
+ };
+}