summaryrefslogtreecommitdiff
path: root/os/fscusat/modules/network.nix
diff options
context:
space:
mode:
Diffstat (limited to 'os/fscusat/modules/network.nix')
-rw-r--r--os/fscusat/modules/network.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/os/fscusat/modules/network.nix b/os/fscusat/modules/network.nix
new file mode 100644
index 0000000..53367f8
--- /dev/null
+++ b/os/fscusat/modules/network.nix
@@ -0,0 +1,18 @@
+{ ... }:
+
+let
+ wan = "ens18";
+in
+{
+ networking = {
+ interfaces.${wan}.ipv4.addresses = [{
+ address = "10.0.8.101";
+ prefixLength = 16;
+ }];
+ defaultGateway = {
+ address = "10.0.0.1";
+ interface = wan;
+ };
+ nameservers = [ "10.0.0.2" "10.0.0.3" ];
+ };
+}