summaryrefslogtreecommitdiff
path: root/os/kay/modules/postgresql.nix
diff options
context:
space:
mode:
Diffstat (limited to 'os/kay/modules/postgresql.nix')
-rw-r--r--os/kay/modules/postgresql.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/os/kay/modules/postgresql.nix b/os/kay/modules/postgresql.nix
new file mode 100644
index 0000000..6f4d126
--- /dev/null
+++ b/os/kay/modules/postgresql.nix
@@ -0,0 +1,17 @@
+{ config, lib, pkgs, ... }: {
+ services.postgresql = {
+ enable = true;
+ package = with pkgs; postgresql_15;
+ authentication = lib.mkForce ''
+ #type database DBuser origin-address auth-method
+ # unix socket
+ local all all trust
+ # ipv4
+ host all all 127.0.0.1/32 trust
+ # ipv6
+ host all all ::1/128 trust
+ '';
+
+ settings.log_timezone = config.time.timeZone;
+ };
+}