summaryrefslogtreecommitdiff
path: root/os/kay/pkgs/matrix-sliding-sync.nix
diff options
context:
space:
mode:
Diffstat (limited to 'os/kay/pkgs/matrix-sliding-sync.nix')
-rw-r--r--os/kay/pkgs/matrix-sliding-sync.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/os/kay/pkgs/matrix-sliding-sync.nix b/os/kay/pkgs/matrix-sliding-sync.nix
new file mode 100644
index 0000000..17051dc
--- /dev/null
+++ b/os/kay/pkgs/matrix-sliding-sync.nix
@@ -0,0 +1,37 @@
+{ lib
+, buildGoModule
+, fetchFromGitHub
+}:
+
+buildGoModule rec {
+ pname = "matrix-sliding-sync";
+ version = "0.99.19";
+
+ src = fetchFromGitHub {
+ owner = "matrix-org";
+ repo = "sliding-sync";
+ rev = "refs/tags/v${version}";
+ hash = "sha256-w4VL+MioNeJ/R48Ln9tYaqlfg7NvT3mQs0dWOZTHQK4=";
+ };
+
+ vendorHash = "sha256-THjvc0TepIBFOTte7t63Dmadf3HMuZ9m0YzQMI5e5Pw=";
+
+ subPackages = [ "cmd/syncv3" ];
+
+ ldflags = [
+ "-s"
+ "-w"
+ "-X main.GitCommit=${src.rev}"
+ ];
+
+ # requires a running matrix-synapse
+ doCheck = false;
+
+ meta = with lib; {
+ description = "Sliding sync implementation of MSC3575 for matrix";
+ homepage = "https://github.com/matrix-org/sliding-sync";
+ license = with licenses; [ asl20 ];
+ maintainers = with maintainers; [ sinanmohd ];
+ mainProgram = "syncv3";
+ };
+}