summaryrefslogtreecommitdiff
path: root/os/lia/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'os/lia/hardware-configuration.nix')
-rw-r--r--os/lia/hardware-configuration.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/os/lia/hardware-configuration.nix b/os/lia/hardware-configuration.nix
new file mode 100644
index 0000000..8417070
--- /dev/null
+++ b/os/lia/hardware-configuration.nix
@@ -0,0 +1,29 @@
+{ modulesPath, ... }:
+
+{
+ imports = [ (modulesPath + "/installer/scan/not-detected.nix") ];
+
+ boot = {
+ loader.systemd-boot.enable = true;
+ kernelModules = [ "kvm-amd" ];
+
+ initrd.availableKernelModules = [
+ "xhci_pci"
+ "ahci"
+ "usb_storage"
+ "usbhid"
+ "sd_mod"
+ ];
+ };
+
+ fileSystems = {
+ "/" = {
+ device = "/dev/disk/by-uuid/9ad3550b-8c9a-4541-8fac-7af185599446";
+ fsType = "ext4";
+ };
+ "/boot" = {
+ device = "/dev/disk/by-uuid/6111-05EC";
+ fsType = "vfat";
+ };
+ };
+}