summaryrefslogtreecommitdiff
path: root/os/lia/modules/users.nix
diff options
context:
space:
mode:
Diffstat (limited to 'os/lia/modules/users.nix')
-rw-r--r--os/lia/modules/users.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/os/lia/modules/users.nix b/os/lia/modules/users.nix
new file mode 100644
index 0000000..26f5dc8
--- /dev/null
+++ b/os/lia/modules/users.nix
@@ -0,0 +1,18 @@
+{ pkgs, ... }: {
+ users.users = {
+ "rohit" = {
+ isNormalUser = true;
+ extraGroups = [ "wheel" ];
+
+ packages = with pkgs; [ git htop ];
+ openssh.authorizedKeys.keys =
+ [ "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIOZcWF1zVyxsCdZ/j+h+RlHZlyhgY2Bky03847bxFNSH rohit@victus" ];
+ };
+
+ "sharu" = {
+ isNormalUser = true;
+ openssh.authorizedKeys.keys =
+ [ "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIMAAaAUTiM3YY7E/7lq44aX+2U0IYhp2Qntu7hINcTjF sharu@lappie" ];
+ };
+ };
+}