summaryrefslogtreecommitdiff
path: root/os/pc/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'os/pc/configuration.nix')
-rw-r--r--os/pc/configuration.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/os/pc/configuration.nix b/os/pc/configuration.nix
new file mode 100644
index 0000000..4cd3a62
--- /dev/null
+++ b/os/pc/configuration.nix
@@ -0,0 +1,27 @@
+{ config, pkgs, ... }: let
+ user = config.global.userdata.name;
+in {
+ imports = [
+ ../common/configuration.nix
+
+ ./modules/getty.nix
+ ./modules/sshfs.nix
+ ./modules/network.nix
+ ./modules/wayland.nix
+ ];
+
+ boot = {
+ consoleLogLevel = 3;
+ kernelPackages = pkgs.linuxPackages_latest;
+ };
+
+ sound.enable = true;
+ services.pipewire = {
+ enable = true;
+ pulse.enable = true;
+ };
+
+ documentation.dev.enable = true;
+ programs.adb.enable = true;
+ users.users.${user}.extraGroups = [ "adbusers" ];
+}