summaryrefslogtreecommitdiff
path: root/os/pc/modules/getty.nix
diff options
context:
space:
mode:
Diffstat (limited to 'os/pc/modules/getty.nix')
-rw-r--r--os/pc/modules/getty.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/os/pc/modules/getty.nix b/os/pc/modules/getty.nix
new file mode 100644
index 0000000..8c7f57e
--- /dev/null
+++ b/os/pc/modules/getty.nix
@@ -0,0 +1,15 @@
+{ config, ... }: let
+ user = config.global.userdata.name;
+in {
+ systemd.services."getty@".serviceConfig.TTYVTDisallocate = "no";
+
+ services.getty = {
+ loginOptions = "-f ${user}";
+ extraArgs = [
+ "--nonewline"
+ "--skip-login"
+ "--noclear"
+ "--noissue"
+ ];
+ };
+}