summaryrefslogtreecommitdiff
path: root/userdata.nix
diff options
context:
space:
mode:
Diffstat (limited to 'userdata.nix')
-rw-r--r--userdata.nix30
1 files changed, 0 insertions, 30 deletions
diff --git a/userdata.nix b/userdata.nix
deleted file mode 100644
index 564f1f0..0000000
--- a/userdata.nix
+++ /dev/null
@@ -1,30 +0,0 @@
-{ config, lib, ... }:
-
-let
- inherit (lib) mkOption types;
- cfg = config.userdata;
-in
-{
- options.userdata = {
- name = mkOption {
- type = types.str;
- default = "sinan";
- description = "Owner's username";
- };
- nameFq = mkOption {
- type = types.str;
- default = "sinanmohd";
- description = "Owner's fully qualified username";
- };
- domain = mkOption {
- type = types.str;
- default = "sinanmohd.com";
- description = "Owner's domain";
- };
- email = mkOption {
- type = types.str;
- default = "${cfg.name}@${cfg.domain}";
- description = "Owner's email";
- };
- };
-}