summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorSomeoneSerge <else@someonex.net>2024-08-01 17:30:15 +0000
committerSomeoneSerge <else@someonex.net>2024-08-03 17:38:58 +0000
commit19c0120754f904c3b0caeb65b3b19d13c4500926 (patch)
treed8c45ee37bd7dc876c73c23aff550d6694cc0578 /flake.nix
parentfb801a2b7d0ae0ed0fc6b3543974bb8e9fc64357 (diff)
nixosTests: init
A PoC that only runs --dry-run, no evanix
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 837785f..8421959 100644
--- a/flake.nix
+++ b/flake.nix
@@ -63,5 +63,13 @@
});
}
);
+ legacyPackages = forAllSystems (
+ { pkgs, ... }:
+ {
+ nixosTests = pkgs.callPackage ./nixos/tests/all-tests.nix {
+ nixos-lib = import (nixpkgs + "/nixos/lib") { };
+ };
+ }
+ );
};
}