aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-09-03 19:18:37 +0530
committersinanmohd <sinan@sinanmohd.com>2024-09-03 19:18:45 +0530
commit50dcf4c300e49a23a72350ff083f2908e5abe888 (patch)
tree8c7038ebcaed498145690feda9221ca8e3e41be1 /flake.nix
parent0a0d4baf28ee0436536c3a9a4da86a88440f49c2 (diff)
flake/checks: use nix from inputs
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 409947c..079ae8b 100644
--- a/flake.nix
+++ b/flake.nix
@@ -90,9 +90,12 @@
}
);
legacyPackages = forAllSystems (
- { pkgs, ... }:
+ { pkgs, system, ... }:
+ let
+ nixPkg = nix.packages.${system}.nix;
+ in
{
- nixosTests = pkgs.callPackage ./nixos/tests/all-tests.nix { };
+ nixosTests = pkgs.callPackage ./nixos/tests/all-tests.nix { nix = nixPkg; };
}
);
checks = forAllSystems (