summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-06-07 15:14:20 +0530
committersinanmohd <sinan@sinanmohd.com>2024-06-07 17:06:13 +0530
commit841b3c6e2148cab8c327e7210b3023c9fc2486c3 (patch)
treeae5a823951a2525d8adef4fc7894d36f3cd5334a /meson.build
repo: init
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build22
1 files changed, 22 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..d5f4f82
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,22 @@
+project(
+ 'evanix',
+ 'c',
+ version : '0.1',
+ license: 'GPL-3.0-only',
+ default_options : [
+ 'c_std=c99',
+ 'warning_level=2',
+ ]
+)
+
+add_project_arguments(
+ [
+ '-Wvla',
+ ],
+ language: 'c',
+)
+
+cjson_dep = dependency('libcjson')
+evanix_inc = include_directories('include')
+
+subdir('src')