aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/all-tests.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-09-03 19:18:37 +0530
committersinanmohd <sinan@sinanmohd.com>2024-09-03 19:18:45 +0530
commit50dcf4c300e49a23a72350ff083f2908e5abe888 (patch)
tree8c7038ebcaed498145690feda9221ca8e3e41be1 /nixos/tests/all-tests.nix
parent0a0d4baf28ee0436536c3a9a4da86a88440f49c2 (diff)
flake/checks: use nix from inputs
Diffstat (limited to 'nixos/tests/all-tests.nix')
-rw-r--r--nixos/tests/all-tests.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/nixos/tests/all-tests.nix b/nixos/tests/all-tests.nix
index 5b9710d..3c663c4 100644
--- a/nixos/tests/all-tests.nix
+++ b/nixos/tests/all-tests.nix
@@ -1,7 +1,12 @@
-{ lib, testers }:
+{
+ lib,
+ testers,
+ nix,
+ callPackage,
+}:
let
- dsl = ./dsl.nix;
+ dsl = callPackage ./dsl.nix { inherit nix; };
diamond.dag = {
nodes.a = { };
nodes.b.inputs.a = { }; # b->a