summaryrefslogtreecommitdiff
path: root/nixos/tests/all-tests.nix
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-08-14 07:19:03 +0530
committersinanmohd <sinan@sinanmohd.com>2024-08-14 07:35:17 +0530
commitb79e15cb07e8540ccc037f9cb80d3082366e7560 (patch)
tree6a1644512fcee4f254675492239946c89e0f3359 /nixos/tests/all-tests.nix
parente1cedc07a2bc987f6eac508cd99e92faa62da081 (diff)
nixosTests/dsl: verify assertChosen
Diffstat (limited to 'nixos/tests/all-tests.nix')
-rw-r--r--nixos/tests/all-tests.nix24
1 files changed, 16 insertions, 8 deletions
diff --git a/nixos/tests/all-tests.nix b/nixos/tests/all-tests.nix
index 68342d6..158c025 100644
--- a/nixos/tests/all-tests.nix
+++ b/nixos/tests/all-tests.nix
@@ -1,4 +1,4 @@
-pkgs:
+{ testers }:
let
dsl = ./dsl.nix;
@@ -54,7 +54,7 @@ in
builtins.mapAttrs
(
name: value:
- pkgs.testers.runNixOSTest (
+ testers.runNixOSTest (
{
inherit name;
testScript = ''
@@ -105,12 +105,20 @@ builtins.mapAttrs
sunset-unbuilt-0 = {
imports = [
{
- # all builds
- dag.needBuilds = 9;
- # all builds allowed
- dag.allowBuilds = 5;
- # chosen builds requested
- dag.choseBuilds = 3;
+ dag = {
+ # all builds
+ needBuilds = 9;
+ # all builds allowed
+ allowBuilds = 5;
+ # chosen builds requested
+ choseBuilds = 3;
+
+ nodes = {
+ a.assertChosen = true;
+ b.assertChosen = true;
+ c.assertChosen = true;
+ };
+ };
}
sunset
];