summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorsinanmohd <sinan@sinanmohd.com>2024-07-30 21:31:51 +0530
committersinanmohd <sinan@sinanmohd.com>2024-07-30 21:59:39 +0530
commit72cf8cfcc59f792ff48eb28c3f760678dc10090c (patch)
tree1aca1af04efe127296bbb5b134babb904a3dbf19 /tests/meson.build
parent1778164794b39d2613b02783bef9beee683de866 (diff)
tests: init
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
new file mode 100644
index 0000000..22ce6b8
--- /dev/null
+++ b/tests/meson.build
@@ -0,0 +1,19 @@
+dag_test = executable(
+ 'dag_test',
+ [
+ 'dag.c',
+ '../src/jobs.c',
+ '../src/util.c',
+ '../src/queue.c',
+ '../src/build.c',
+ '../src/jobid.c',
+ '../src/solver_conformity.c',
+ '../src/solver_highs.c',
+ '../src/solver_sjf.c',
+ ],
+
+ include_directories: evanix_inc,
+ dependencies: [ cjson_dep, highs_dep ],
+)
+
+test('dag', dag_test)