diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 7 |
1 files changed, 5 insertions, 2 deletions
@@ -90,9 +90,12 @@ } ); legacyPackages = forAllSystems ( - { pkgs, ... }: + { pkgs, system, ... }: + let + nixPkg = nix.packages.${system}.nix; + in { - nixosTests = pkgs.callPackage ./nixos/tests/all-tests.nix { }; + nixosTests = pkgs.callPackage ./nixos/tests/all-tests.nix { nix = nixPkg; }; } ); checks = forAllSystems ( |