aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/all-tests.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/all-tests.nix')
-rw-r--r--nixos/tests/all-tests.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/nixos/tests/all-tests.nix b/nixos/tests/all-tests.nix
index 5b9710d..3c663c4 100644
--- a/nixos/tests/all-tests.nix
+++ b/nixos/tests/all-tests.nix
@@ -1,7 +1,12 @@
-{ lib, testers }:
+{
+ lib,
+ testers,
+ nix,
+ callPackage,
+}:
let
- dsl = ./dsl.nix;
+ dsl = callPackage ./dsl.nix { inherit nix; };
diamond.dag = {
nodes.a = { };
nodes.b.inputs.a = { }; # b->a